Kendryte IDE提供的软件包里面有报错



  • 在Kendryte IDE Bate版中下载软件包后再安装全部依赖,发现在依赖的fft.c等文件中存在以下报错
    Inked截图_2020071415382238SS_LI.jpg
    图片中显示位域无效,看样子是设定的值“46”超过了范围,但是它前面不是“uint64_t”修饰的吗,应该并没有超过范围才对啊,请问这是哪儿出问题了。



  • 是否方便将工程打包传上来?



  • @mangogeek 我是直接在IDE里面下载的工程,没有进行任何修改。你可以随便下载一个工程然后去fft.h文件中看一看,就会显示这样的报错(至少我这电脑上面是这样)。而且我发现只要把uint64_t重定义为unsigned long long就没问题了


Log in to reply
 

2
Online

951
Users

576
Topics

2.3k
Posts